register for free
View our sister sites
Our sister sites
Our sister sites
Our sister sites
Stewart
Dogsey Veteran
Stewart is offline  
Location: Leicestershire
Joined: Jun 2005
Posts: 10,627
Male 
 
26-02-2006, 06:02 PM

Digital Camera Problem

Every time i turn it on it switches off again
i tried warming the batteries on the radiator because they were very cold which helped for awhile but it's started again
they are new batteries
anyone else have this problem
Reply With Quote
Steve
Dogsey Veteran
Steve is offline  
Location: Pancake flat East Anglia
Joined: Apr 2005
Posts: 10,028
Male 
 
26-02-2006, 06:35 PM
What make of camera is it Stew???
Reply With Quote
Stewart
Dogsey Veteran
Stewart is offline  
Location: Leicestershire
Joined: Jun 2005
Posts: 10,627
Male 
 
26-02-2006, 06:39 PM
Sony DSC-S40
Reply With Quote
Steve
Dogsey Veteran
Steve is offline  
Location: Pancake flat East Anglia
Joined: Apr 2005
Posts: 10,028
Male 
 
26-02-2006, 07:28 PM
The reason i ask Stew is cause i have a Hewlett Packard camera and mine did this a few weeks ago when it was bitterly cold & i was trying to take piccys.I just slipped it into a warm inside pocket for a while and it worked alright then.

My camera also wont take piccys when the batteries get down to a certain mark despite me using them afterwards for remote controls,clocks etc which is a real pain.What make of batteries are you using cause i find the top spec (and mighty expensive) Duracell ones last longer than Energisers.

ps-I wouldnt put the batteries on a radiator though incase they explode!
Reply With Quote
Foxy
Dogsey Veteran
Foxy is offline  
Location: uk
Joined: Mar 2005
Posts: 21,778
Female 
 
26-02-2006, 07:41 PM
Yes sounds very much like a battery problem to me too. Can you not use the rechargeable AA ones Stewart because they last for quite a time and are easily charged up again in a few hours. I have seen the battery charger and batteries on sale for 12.99 at quite a few places recently.
Reply With Quote
Stewart
Dogsey Veteran
Stewart is offline  
Location: Leicestershire
Joined: Jun 2005
Posts: 10,627
Male 
 
26-02-2006, 07:50 PM
i only put them on the radiator for a couple of minutes
I use rechargable panasonic ones
Reply With Quote
Stewart
Dogsey Veteran
Stewart is offline  
Location: Leicestershire
Joined: Jun 2005
Posts: 10,627
Male 
 
26-02-2006, 07:52 PM
Never have this problem with my SLR
Reply With Quote
Foxy
Dogsey Veteran
Foxy is offline  
Location: uk
Joined: Mar 2005
Posts: 21,778
Female 
 
26-02-2006, 07:52 PM
Originally Posted by Stewart B
i only put them on the radiator for a couple of minutes
I use rechargable panasonic ones

Oh right - have you been using them for quite a bit before they run down then or are they not charging up properly I have never used the panasonic ones - I always get the Uniross ones.
Reply With Quote
Foxy
Dogsey Veteran
Foxy is offline  
Location: uk
Joined: Mar 2005
Posts: 21,778
Female 
 
26-02-2006, 07:53 PM
Originally Posted by Stewart B
Never have this problem with my SLR


er.....whats a SLR?
Reply With Quote
Stewart
Dogsey Veteran
Stewart is offline  
Location: Leicestershire
Joined: Jun 2005
Posts: 10,627
Male 
 
26-02-2006, 07:54 PM
I have no trouble charging them
Reply With Quote
Reply
Page 1 of 3 1 2 3 >


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


© Copyright 2016, Dogsey   Contact Us - Dogsey - Top Contact us | Archive | Privacy | Terms of use | Top