register for free
View our sister sites
Breedia
Over 50s Forum
Catsey
Fudgeley
Dogsey Veteran
Fudgeley is offline  
Location: Warrington UK
Joined: Nov 2006
Posts: 9,925
Female 
 
06-04-2009, 03:13 PM

Dyson just stopped working.

My Dyson has just stopped. No bangs, pops or smoke. It as just as if someone had switched it off....I have just checked fo blockages but all sems ok. It did feel quite warm though when I removed the dust cylinder section.

Any ideas?
Reply With Quote
Hali
Dogsey Veteran
Hali is offline  
Location: Scottish Borders
Joined: Nov 2006
Posts: 13,900
Female 
 
06-04-2009, 03:18 PM
Have you checked the fuse in the plug?
Reply With Quote
Fudgeley
Dogsey Veteran
Fudgeley is offline  
Location: Warrington UK
Joined: Nov 2006
Posts: 9,925
Female 
 
06-04-2009, 03:23 PM
Hmmmmm,that might be agood idea!
Reply With Quote
Vicki
Dogsey Veteran
Vicki is offline  
Location: In a land far, far away
Joined: Sep 2005
Posts: 41,933
Female 
 
06-04-2009, 03:24 PM
The older modules stop working if the filter needs changing - try that hon x
Reply With Quote
Benzmum
Dogsey Veteran
Benzmum is offline  
Location: Scotland
Joined: Jul 2006
Posts: 2,966
Female 
 
06-04-2009, 03:27 PM
My hoover (non dyson) did that the other day, have a look at the rollers etc and see if it has picked up hair thread or elastic that has wrapped itself round the rollers, thtas what happened to mine and that in turn burnt the belt but it was simple to change and hoover worked fine after I hhad removed loads of hair and threads that had wrapped themselves round the bottom.

Good luck
Reply With Quote
Fudgeley
Dogsey Veteran
Fudgeley is offline  
Location: Warrington UK
Joined: Nov 2006
Posts: 9,925
Female 
 
06-04-2009, 03:34 PM
I will try all of the above later. My youngest has just kindly given me a manicure with bright red polish!!!!!!!!!!hmmmmm
Reply With Quote
Fudgeley
Dogsey Veteran
Fudgeley is offline  
Location: Warrington UK
Joined: Nov 2006
Posts: 9,925
Female 
 
06-04-2009, 03:45 PM
filter washed and duly drying on radiator. It was minging!!! Hopefully that will be it.

I went on the Dysoin site. They have a great 24hr hour sale!!
Reply With Quote
Chris_Collins
Dogsey Junior
Chris_Collins is offline  
Location: Auckland Central
Joined: May 2008
Posts: 205
Male 
 
07-04-2009, 07:00 AM
Yep it'll be the filters. The motor has some sort of safety cut out switch if the engine gets too hot. Our DC08 animal did this all the time (eventually we switched to an upright dysonesque hoover which worked a hell of a lot better too..)
Reply With Quote
nero
Dogsey Veteran
nero is offline  
Location: central scotland
Joined: May 2007
Posts: 4,637
Male 
 
07-04-2009, 10:49 AM
You've been working too hard, the thermal cut-out has tripped in, take a break, have a coffee , once it's cooled down it'll re-start.
Reply With Quote
Fudgeley
Dogsey Veteran
Fudgeley is offline  
Location: Warrington UK
Joined: Nov 2006
Posts: 9,925
Female 
 
07-04-2009, 11:22 AM
Originally Posted by nero View Post
You've been working too hard, the thermal cut-out has tripped in, take a break, have a coffee , once it's cooled down it'll re-start.
LOL, it was my cleaner not me!!
Reply With Quote
Reply
Page 1 of 2 1 2 >


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


© Copyright 2016, Dogsey   Contact Us - Dogsey - Top Contact us | Archive | Privacy | Terms of use | Top